KX Riders
  Home Help Login Register   *
Welcome, Guest. Please login or register.
Did you miss your activation email?
June 18, 2019, 06:32:53 AM

Login with username, password and session length
Recent
[June 17, 2019, 06:11:17 PM]

[June 17, 2019, 06:08:11 PM]

[June 17, 2019, 06:07:32 PM]

[June 17, 2019, 06:05:06 PM]

[June 17, 2019, 12:27:48 PM]

[June 17, 2019, 08:58:43 AM]

[June 16, 2019, 09:53:43 PM]

[June 16, 2019, 04:03:18 PM]

[June 14, 2019, 09:16:22 AM]

[June 12, 2019, 09:06:46 PM]

[June 12, 2019, 03:04:32 PM]

[June 12, 2019, 02:11:14 PM]

[June 12, 2019, 11:19:25 AM]

[June 12, 2019, 08:19:15 AM]

[June 11, 2019, 10:32:52 PM]
Pages: 1 [2]   Go Down
  Print  
Author Topic: Impeller seal??  (Read 1516 times)
0 Members and 1 Guest are viewing this topic.
reklessj
Hero Member
*****
Offline Offline

Joined: 02.15.11
Posts: 889



« Reply #15 on: January 02, 2019, 06:49:18 PM »

So I'm finally getting around to fixing my issues. One more question I can't for the life of me find the MOS2 Grease that the manual calls for lubing the seal and shaft. Is there any other options for the type of Grease I can use?
Logged

My rides: 1994 KX500, 1988 T4, 1998, ZXI 1100 JETSKI, 2003 MOUNTAIN CAT 900
WIFES (Baby Fiver) rides: 2004 KTM 105SX,1992 LT250R, 1995 ZXI 900 JETSKI,  2011 RMK 600
SONS ride: 1995 YZ125,2002 RM 250
other rides: 2007 RMZ450 RC Ediition, 2003 RMK700
Pages: 1 [2]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
TinyPortal v0.9.7 © Bloc
Valid XHTML 1.0! Valid CSS!
Page created in 0.11 seconds with 28 queries.