KX Riders
  Home Help Login Register   *
Welcome, Guest. Please login or register.
Did you miss your activation email?
September 22, 2018, 09:18:18 PM

Login with username, password and session length
Recent
[Today at 08:22:21 PM]

[Today at 03:03:57 PM]

[Today at 02:30:00 AM]

[September 21, 2018, 08:55:13 PM]

[September 20, 2018, 08:12:17 PM]

[September 20, 2018, 05:53:07 PM]

[September 20, 2018, 11:29:29 AM]

[September 20, 2018, 09:09:24 AM]

[September 20, 2018, 08:21:25 AM]

[September 20, 2018, 08:19:47 AM]

[September 20, 2018, 08:18:15 AM]

[September 19, 2018, 02:04:45 PM]

[September 18, 2018, 04:18:02 PM]

[September 18, 2018, 02:59:40 PM]

[September 18, 2018, 10:43:06 AM]
Pages: [1]   Go Down
  Print  
Author Topic: 2006 kawasaki kx250f engine plug help!!  (Read 566 times)
0 Members and 1 Guest are viewing this topic.
Sploon
Newbie
*
Offline Offline

Joined: 11.27.17
Posts: 4


« on: March 05, 2018, 06:51:36 AM »

I just got my bike out for the season first ride of the year when my day was cut short because my engine cover plug (92066-0039 PLUG,12X9.1 ) fell out at some point during my ride and got oil everywhere. Now this happened to me last year as well so i just ordered a new OEM plug and thought that would fix my problem. Clearly it did not. The threads on the cover do not look stripped. What do you recommend? Is it okay to use locktite on the plug?
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
TinyPortal v0.9.7 © Bloc
Valid XHTML 1.0! Valid CSS!
Page created in 0.158 seconds with 27 queries.